This forum is for traders to share information about OptionVue analytical software.

Strange Backtesting Results. Can anyone duplicate?

Tagged: , , , ,

10 replies, 4 voices Last updated by David Fraser 5 years, 4 months ago
Viewing 10 reply threads
  • Author
    Posts
    • #2794

      David Fraser
      Participant
      @fradav68@gmail.com
      Points: 258
      Rank: Freshman

      Wow, I am astonished, I had small slippage as my setting in the model (but not in the info) and not only did unchecking this correct the issue in backtrader but transferred my live position t-0 line.

      Solved a lot of other issues I struggled with too (how SPX trades looked so much better than RUT in OV modelling). My current RUT M3 trade (negative 90 delta) is now flat with a 5% drop versus down $9,000 with small slippage. Have been taking on excessive negative delta and getting hit on upside due to this.

      Do not get the rationale behind slippage affecting my t-0 line but very glad I found out.

      Thanks a lot John.

    • #2789

      John Locke
      Keymaster
      @john-locke
      Going to The Trading Triangle LIVE 2016Locke In Your Success CoachAPM2Trade JournalsUltimate Income Trader Workshop

      Make sure slippage is unchecked in the info screen
      .
      Make sure slippage in model screen is set to none

    • #2787

      David Fraser
      Participant
      @fradav68@gmail.com
      Points: 258
      Rank: Freshman

      Ive spent a week or so backtesting M3 and BB, despite my real-life experience I almost cant make money on an M3 backtesting whereas its hard to lose on the BB (with a few exceptions).

      However I notice theres huge slippage on my M3 trades, and the M3 has a lot more adjusting than the BB. I understand its not easy to recover losses on an M3 and when its down right from the get-go backtesting then its hard to profit.

      For example (attached) I just took a random May 50/100/50 butterfly entered on March 17, 2015, converted it (down a lot on entry), closed the trade immediately and moved it up without any price movements. Down $13,450 on entry (checking “r” column doesnt help)

      Is there something Im doing wrong? I see the t-log prices are not mkt price and I adjust on trade entry to get to zero, but impossible to do as trade goes on.

       

    • #2137

      John Locke
      Keymaster
      @john-locke
      Going to The Trading Triangle LIVE 2016Locke In Your Success CoachAPM2Trade JournalsUltimate Income Trader Workshop

      Thank you Cindy

    • #2136

      Cynthia Sarver
      Participant
      @wawd@yahoo.com
      Points: 911
      Blog WriterGoing to The Trading Triangle LIVE 2016APM2 LIVE AttendeeSuccessful Options Trader of the Month30 Day Affirmation ChallengeTrade Journals
      Rank: Freshman

      Bryan – ugh. I’m so sorry! I’ve sent Sherri the new document which also adds the Recon column since it no longer defaults, either. She can replace the document in the Resources folder and it will work … for now, anyway. *sigh* Another catastrophic improvement in OV! I’ll also write up a bug report for them.
      .
      My apologies for the confusion but I’m glad that we got it straightened out!
      .
      Happy Backtesting!
      -cindy

    • #2135

      Anonymous One
      Participant
      @anonymous@lockeinyoursuccess.com
      Points: 2
      Rank: Newbie

      Cindy, that definitely fixed the issue!

      John, sorry for taking your time on this. This explains why we were seeing different results for the same t-log in our emails last week.

    • #2134

      Anonymous One
      Participant
      @anonymous@lockeinyoursuccess.com
      Points: 2
      Rank: Newbie

      Cindy, thanks you!!!
      This was driving me crazy and I have probably been driving John crazy. I did use the resources document to setup my imports. I will redo and report back.

    • #2133

      Cynthia Sarver
      Participant
      @wawd@yahoo.com
      Points: 911
      Blog WriterGoing to The Trading Triangle LIVE 2016APM2 LIVE AttendeeSuccessful Options Trader of the Month30 Day Affirmation ChallengeTrade Journals
      Rank: Freshman

      Bryan – good news! You’re not crazy. There’s some bug in the OV import that isn’t calculating the Net correctly (as you suspected). The other good news is that there is an easy fix – since the Net column is included in the TLog, you can modify your import to add that, instead of using Placeholder. (I’m guessing that you were using the document on how to import CSV files in the Resources folder; alas, I am the author of that and it USED to work, honest! Anyway, if that’s what you were using, you put in a Placeholder for the Net column, since I figured it was more accurate to have OV calculate the total. Silly me! I should have known better.) Anyway, if you switch to Net, you’ll see very different Net numbers which will result in very different PnL numbers. I’ll redo the How to Import sheet and send it to Sherri to update. Sorry!
      .
      -cindy

    • #2130

      Anonymous One
      Participant
      @anonymous@lockeinyoursuccess.com
      Points: 2
      Rank: Newbie

      Yes, I have both 1 and 2 setup OK.

      The problem starts with the 10/28 adjustments. If I delete the 10/28 adjustments and just advance to 10/29 the P/L goes from about $200 to $800 on 10/29. If I enter the 3 adjustment manually or if I just use the original t-log I downloaded the P/L drops dramatically after the 10/28 adjustments. When I enter the 3 10/28 adjustments myself the P/L drops to -13,000 as soon as I hit the convert trades button.

      I attached the t-log after I applied the adjustment and the numbers in the NET column do not look right and are creating the approx. -13,000 P/L.

      This is an ov bug? I am still on 7.83. Or something else? In the past I have done a lot of ov backtesting and have never seen this until now.

      I checked all the option prices right before and after 10/28 and they all seem reasonable.

    • #2128

      John Locke
      Keymaster
      @john-locke
      Going to The Trading Triangle LIVE 2016Locke In Your Success CoachAPM2Trade JournalsUltimate Income Trader Workshop

      Bryan,

      Yes that is an OV issue.
      Two things, 1. make sure you put a number or letter (the same letter or number) in the “r” column in the tlog

      2. press the info button to open the account and make sure ” G/L to include previously realized G/L’s” is checked

    • #2116

      Anonymous One
      Participant
      @anonymous@lockeinyoursuccess.com
      Points: 2
      Rank: Newbie

      I am doing some backtesting of John’s trades with the t-logs he has posted on the Resources page. https://members.lockeinyoursuccess.com/resources/

      I like to take the trade entry of one of these trades then trade it like I would trade before looking at what John did. Then I load the full t-log and compare what John did to what I did.

      But I keep running into strange pricing and p&L issues. I posted a picture. I am testing the Nov 15 M3 t-log just walking thru John’s trade day by day and then on 11/2/15 I see a huge drop in value and the P&L drops to -16,000.

      Anyone want to import this t-log and see if you are getting the same results? Nov-15 M3 is the name of the t-log.

      I am on ov 7.83 and have not upgraded to the latest release. I have all my ov settings set to the recommended ones on the resource page and have checked this a few times.

      I have had this happen on other t-logs that I have imported like the Sep-15 M3.

      So asking if someone can import the Nov-15 M3 and go to 11/2/15 in backtester to see if your results are similar to what I attached.

      Thanks for any help here.

      Bryan

Viewing 10 reply threads
  • You must be logged in to reply to this topic.